CM Tool Version 9 or 2020, Write to system is not supported for PME 9.0 (Standalone, English, DataCenter, 9.1) to PME (Standalone, English, Standard, 9.1)
Power Monitoring Expert (PME) 2020
Power Monitoring Expert (PME) 9.0
Environment
Configuration Manager CM Tool 9 or CM Tool 2020, 'Write to System' process.
Cause
In SBS upgrade:
- Using CM Tool v.2020 to transfer the configuration from old PME 9.0 server to new PME 2020 server
- Using CM Tool v.9 to transfer the configuration from old PME 9.0 server to new PME 9.0 server
- Using CM Tool v.9 to create the Archive from old PME 9.0 server and Write that Archive to the new PME 2020 server with CM Tool 2020.
Write to System soft button is gray and disabled with the following Error message when hovering over it:
CM Tool 2020 (Cause 1):
'Write to system is not supported for Power Monitoring Expert 9.0 (Standalone, English, DataCenter, 9.1) to Power Monitoring Expert 9.1 (Standalone, English, Standard, 9.1)'
CM Tool 9 (Cause 2):
'Write to system is not supported for Power Monitoring Expert 9.0 (Standalone, English, DataCenter, 9.0) to Power Monitoring Expert 9.0 (Standalone, English, Standard, 9.0)'
CM Tool 2020 (Cause 3):
'Write to system is not supported for Power Monitoring Expert 9.0 (Standalone, English, Standard, 9.0) to Power Monitoring Expert 9.1 (Standalone, English, Standard, 9.1)'
PME9.0 only has a single type of installer Standard, unlike the older versions of PME that had Data Center, Health Care and Standard editions.
Causes 1, 2: This issue happens when the old server previously had for example PME8.2 DC and upgraded to PME 9.0, then it converted to PME 9.0 standard plus some additional modules like Backup Power Module and Insulation Monitoring Module.
'Data Center' in that message is not correct, and this resolution forces CM Tool to accept it regardless.
Cause 3: This issue happens when moving from old PME 9.0 to PME 2020, CM Tool v.9 is used to create Archive in old PME 9.0 system which causes CM Tool 2020 'Write to System' to be Gray or disabled.
Resolution
Solution for cause 1,2:
In order to enable the 'Write to System' button, edit the 'SupportedVersion' xml file under CM Tool installed folder as mentioned in the following steps and image:
- Go to CM tool folder\bin
- Open SupportedVersions.xml in notepad
- Find the item below,
<From Version="9.0" InstallationTypes="Standalone,Distributed" Languages="en" Editions="" />
<To Version="9.1" InstallationTypes="Standalone,Distributed" Languages="en" Editions="" />
</SupportedVersion>
- Change it to
<From Version="9.0" InstallationTypes="Standalone,Distributed" Languages="en" Editions=",DataCenter" />
<To Version="9.1" InstallationTypes="Standalone,Distributed" Languages="en" Editions="" />
</SupportedVersion>
- Save the file and run CM tool to write the archive into new PME server.
Note: When using CM Tool v.9 to move configuration files from old PME 9 server to new PME 9 server, the steps are the same as above, and because the InstallationTypes are specified as "Standalone" or "Distributed" in two separate lines depending on the PME configuration that CM Tool 9 is running, make sure to edit the correct one.
For example here the InstallationTypes="Standalone" and To Version is "9.0" instead of "9.1".
<SupportedVersion>
<From Version="9.0" InstallationTypes="Standalone" Languages="en" Editions="" />
<To Version="9.0" InstallationTypes="Standalone" Languages="en" Editions="" />
</SupportedVersion>
And change it to:
<SupportedVersion>
<From Version="9.0" InstallationTypes="Standalone" Languages="en" Editions=",DataCenter" />
<To Version="9.0" InstallationTypes="Standalone" Languages="en" Editions="" />
</SupportedVersion>
Solution for cause 3:
When using CM Tool 2020 to 'Write to System' in PME 2020, the created Archive from old PME 9.0 system should be created by CM Tool 2020, otherwise the 'Write to System' is Gray and disabled.
Publikováno pro: Schneider Electric Česká republika


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