Workaround for problem adding a secondary language to EGX300
Title:
Workaround for problem adding a secondary language to EGX300
Issue:
After following the procedure “EGX300 Secondary Language Support.doc”, the secondary language does not appear in the EGX300 language selection list (the new language is not shown even after selecting it).
IE 7.0
]
IE 6.0 -
Product Line:
PowerLogic™ EGX300
Environment:
EGX300 web interface (User Accounts / Language selection)
Attempting to add/configure a secondary language using the procedure:
“EGX300 Secondary Language Support.doc”
Editing and uploading the language CSV (download to EGX300 via FTP)
Cause:
Microsoft Excel saves CSV files in UTF‑8 format in a way that does not work for this EGX300 secondary language process. Even using Excel’s “Save As” options for encoding still results in UTF‑8 encoding, and the output file does not behave correctly on the EGX300. This does not appear to be related to the Excel version.
Resolution:
Use Notepad instead of Microsoft Excel to edit and save the secondary language CSV.
Workaround steps (example uses Chinese as the target language):
- Follow “EGX300 Secondary Language Support.doc” to Step 3 and remove all languages except English.
- Save the CSV, then open it using Notepad.
- Replace all items/strings with the local language values in Notepad.
- Save the CSV in Notepad using these options:
- File name:
language_secondary.csv - Save as type:
All Files - Encoding:
UTF-8
- File name:
5.After downloading (uploading) to the EGX300 using FTP, the new language should appear and be selectable.
Udgivet til: Schneider Electric Danmark







