このページでは、富士通株式会社製 Smart-UPS C500JとPowerChute Business Edition v10.0の組み合わせで、スケジュールシャットダウン実行時にサーバが指定時刻に起動しない問題について説明しています。
【対象製品】
以下の組合せにおいてまれに発生することが確認されております。
PowerChute Business Edition for Windows v10.0
対象UPS: Smart-UPS C500J
本問題はバージョン10.0.2で解消しています。
【問題の概要】
PowerChute上で「スケジュールされたシャットダウン」の実行、またはUPSSleepによるスケジュールシャットダウン処理において、指定した起動時刻になってもサーバが起動しない
【問題の発生条件】
以下のどちらかの場合に本事象がまれに発生することがあります。
・ 「スケジュールされたシャットダウン」を用いてスケジュールタスクを実行したとき
・ UPSSleepを使ってスケジュールシャットダウンを実行したとき
【原因】
スケジュールで指定した時刻までUPSがスリープ状態となるようにPowerChuteはUPSに対してスリープ命令を書き込みます。
本来は上記によって、UPSがスリープ状態に移行し、スリープカウントが完了した時点(起動時刻)で自動的にUPSは復電し、サーバも起動します。
本問題は、PowerChuteからスリープ命令実行時に、UPSの内部処理の応答遅延が原因で発生します。
3秒以上UPSから応答が遅延した場合にPowerChuteはスリープ命令をキャンセルし、サーバのシャットダウンのみを実行します。
その結果、UPSはスリープ状態には移行せずにオンライン状態を継続するため、スケジュールの指定時刻にサーバは起動しません(UPSの自動復電が行われないため)。
【回避方法】
バージョン10.0.2へアップデートしてください。
バージョン10.0.2でない場合、本事象が発生した場合は手動にてサーバの起動を実行してください。
【対象製品】
以下の組合せにおいてまれに発生することが確認されております。
PowerChute Business Edition for Windows v10.0
対象UPS: Smart-UPS C500J
本問題はバージョン10.0.2で解消しています。
【問題の概要】
PowerChute上で「スケジュールされたシャットダウン」の実行、またはUPSSleepによるスケジュールシャットダウン処理において、指定した起動時刻になってもサーバが起動しない
【問題の発生条件】
以下のどちらかの場合に本事象がまれに発生することがあります。
・ 「スケジュールされたシャットダウン」を用いてスケジュールタスクを実行したとき
・ UPSSleepを使ってスケジュールシャットダウンを実行したとき
【原因】
スケジュールで指定した時刻までUPSがスリープ状態となるようにPowerChuteはUPSに対してスリープ命令を書き込みます。
本来は上記によって、UPSがスリープ状態に移行し、スリープカウントが完了した時点(起動時刻)で自動的にUPSは復電し、サーバも起動します。
本問題は、PowerChuteからスリープ命令実行時に、UPSの内部処理の応答遅延が原因で発生します。
3秒以上UPSから応答が遅延した場合にPowerChuteはスリープ命令をキャンセルし、サーバのシャットダウンのみを実行します。
その結果、UPSはスリープ状態には移行せずにオンライン状態を継続するため、スケジュールの指定時刻にサーバは起動しません(UPSの自動復電が行われないため)。
【回避方法】
バージョン10.0.2へアップデートしてください。
バージョン10.0.2でない場合、本事象が発生した場合は手動にてサーバの起動を実行してください。