Issue
On a PME 9.0 system with CU2 applied; if the Database Manager is used to create a new ION_Data database, the stored procedures
Product Line
Power Monitoring Expert 9.0
Environment
Power Monitoring Expert 9.0 CU2
Cause
Commulitavie updates 2 (CU2) for PME 9.0 adds the CleanCorruptIncidentsAndAlarms as a stored procedure and also updates the existing ClearAllProcessedAlarmData stored procedure. If the Database Manager (or PME reconfigure) is used to create a new ION_Data after applying CU2, dbo.CleanCorruptIncidentsAndAlarms stored procedure will be missing and dbo.ClearAllProcessedAlarmData will not be up to date.
The stored procedures can be found in SQL Server Management Studio (SSMS), expand Databases-->ION_Data-->Programability-->Stored Procedures
Resolution
In order to update the newly created ION_Data database, run the CU2 installer in Reconfigure mode using the following steps;
On a PME 9.0 system with CU2 applied; if the Database Manager is used to create a new ION_Data database, the stored procedures
- dbo.CleanCorruptIncidentsAndAlarms is missing and
- dbo.ClearAllProcessedAlarmData is not up to date.
Product Line
Power Monitoring Expert 9.0
Environment
Power Monitoring Expert 9.0 CU2
Cause
Commulitavie updates 2 (CU2) for PME 9.0 adds the CleanCorruptIncidentsAndAlarms as a stored procedure and also updates the existing ClearAllProcessedAlarmData stored procedure. If the Database Manager (or PME reconfigure) is used to create a new ION_Data after applying CU2, dbo.CleanCorruptIncidentsAndAlarms stored procedure will be missing and dbo.ClearAllProcessedAlarmData will not be up to date.
The stored procedures can be found in SQL Server Management Studio (SSMS), expand Databases-->ION_Data-->Programability-->Stored Procedures
Resolution
In order to update the newly created ION_Data database, run the CU2 installer in Reconfigure mode using the following steps;
- Navigate to Program Files (x86)\Schneider Electric\Power Monitoring Expert\Uninst_PME 9.0 Cumulative Update 2.
- Right-click on Setup.exe and Run as Administrator.
- Select Reconfigure.