Issue
ETL EGX extract task fails for PAS600 and PAS800 FW 1.6.0 csv files.
Product Line
PAS600/800
ETL
EPO/PME
Environment
PAS600 FW1.6.0/PAS800 FW1.6.0
ETL V5.0/V6.0
Cause
In PAS FW 1.6.0 csv file format is modified, all the fields in csv file are included with double quotation (“”) to support special characters for international languages and for better file transfer performance.
Resolution
Please find attached the ETL hotfix151123, which has a fix for the issue reported on ETL V6.0 EGX300 extract job failure due to change in csv file format of Panel Server. The new format of the csv files were with double quotes and in this fix it is parsed to resolve the error.
Work around - Below work around is obsolete. Please use the ETL hotfix attached.
Work around for this issue is to run the attached PowerShell script in the system before the ETL job runs.
Please find the attached PowerShell script to remove the " in the .csv file. Follow the below steps
1. Modify the PowerShell script with your input folder in the highlighted section. If you have multiple folders, repeat the same in the script.
2. Run the PowerShell script once after the SFTP publishing interval.
3. Configure windows task scheduler to run the script periodically once after the SFTP interval.
4. Important Note : Please modify the ETL extract task settings -> File Limit section -> Sort Files by Last Write Time.
5. Make sure that the modified PowerShell script schedule executes before the ETL jobs schedule.
This will resolve the issue.
Note
- This issue is not present in lower firmware versions. i.e., lesser than FW1.6.0
- This issue is addressed in ETL hotfix.