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A Direct Ethernet device associated with a custom MDI driver shows "Device Connected" in Management Console but does not communicate in Vista

Issue
A Direct Ethernet connected device that is associated with a custom Device Type Editor (DTE) communications driver shows "Device Connected" in Management Console but does not communicate in Vista.

In the Diagnostics Viewer the tree state shows "dirty/Not Responding" and the System Log Events displays the following error: Response Error (-1): DL_Timedout:Request Timed out.

When the diagram is open in Vista,the following error message is displayed:

Communication error message: This node is not responding

"Communication Error" Please resolve the problem and try again.
This Node is not responding,

After selecting continue, the Vista objects display a yellow boarder indicating a possible communications issue.

Product Line:

Struxureware Power Monitoring 7.0(SPM)

Power Monitoring Expert 7.2.x

Power Monitoring Expert 8.x

Power Monitoring Expert 9.0

Power Monitoring Expert 2020

Power Monitoring Expert 2021

Power Monitoring Expert 2022

Power Monitoring Expert 2023

Power Monitoring Expert 2024




Environment
Device Type Editor

Modbus Device Importer (For versions prior to PME 9.0)

Cause
When adding a device in Management Console as direct ethernet device, the system does not use a Modbus address/Unit ID by default.
In this example the device type in use requires a Modbus Address/Unit ID for successful communications.

Resolution
Configure the "Unit ID" setting appropriately in the device's Advanced Properties window which can be accessed by opening the "Configure Device" window from the devices tab in Management Console, right clicking in the "Ethernet Device Configuration" window, and selecting "Advanced Properties".

Ethernet Device Configuration from Management Console





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