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Alarm Page in PME 9.0 - After upgrade, why is the alarm web page unable to update the result? The server either timed out or returned invalid result.

Published date: 18 December 2019

Product Line
Power Monitoring Expert (PME) 9.0

Environment
Web Applications "Alarms" 

Cause
PME 9.0 Web App-Alarms tab does not show Alarms and red message note shows up: 'Unable to update the result? The server either timed out or returned invalid result. if this problem persists please contact the system administrator.' 



Resolution
To resolve this problem:
Log into the SQL server through SSMS, select ApplicationModules, Tables, right click on Diagnostics.LogEvent Table and Select Top 1000 Rows.
In order to see the latest messages in result section, go to script section and add new line with: order by TimeStamp desc
Click on 'Execute' button
This will sort the events messages based on the latest event happened in PME Web Application.
When result sorted by TimeStamp, you will find messages indicating:

A problem occurred on page 'https://........./Alarms/data/incidents': Could not find file 'C(Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\EnumAndEvent.en-US.resx'.

A problem occurred on page 'https://........./Alarms/data/alarmdefinitions': Could not find file 'C(Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\IonNames.en-US.resx'.


Go to the folder C:(or Drive name where PME installed):\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\etc\
And find the files named with: EnumAndEvent.en.resx and IonNames.en.resx .

First copy these files as backup in diferent folder and then rename them as follows:
EnumAndEvent.en.resx rename it to EnumAndEvent.en-US.resx
IonNames.en.resx rename it to IonNames.en-US.resx

After renaming the files, close the Web Application and reopen the Alarm page, it will show up the alarms.




 
 

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