Чим ми можемо вам допомогти сьогодні?

Web Reporter fails to install report packs: "Object reference not set to an instance of an object".

Issue:

When installing default report packs with either the command line utility or configuration wizard, installation fails and shows:

System.NullReferenceException: Object reference not set to an instance of an object
and references a pack such as:
C:\Program Files\Schneider Electric\ION Enterprise\Web\ReportPacks\Default Reports 6.0.zip

Product Line:

PME 8.0

Environment:

Legacy Web Reporter
ION_Network database

Cause:

The ION_Network database schema version does not match the installed software (for example, a 6.0 database copied into a 6.0 SP1 system without being upgraded). In this condition, Web Reporter cannot find required assets during pack installation and throws a NullReferenceException.

Warning: Irreparable database damage can occur. Only users familiar with SQL Server Management Studio should perform this procedure.

Resolution:

  1. Verify the database version
    Open ION_Network.dbo.Registry and check the Revision value. If it does not correspond to the installed product level, the database must be upgraded.
  2. Upgrade ION_Network
    Use Database Manager from the Management Console to upgrade ION_Network to the correct version. Confirm completion without errors.
  3. Ensure services are ready
    Confirm SQL Server Agent is running and the application services for reporting are started.
  4. Re‑install report packs
    Run the configuration wizard again. The installation should complete successfully with the corrected schema.

Recommendation:

If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com

support information

Schneider Electric Україна

Досліджуйте більше
Серія:
Досліджуйте більше
Серія:

Потрібна допомога?

Потрібна допомога?

Почніть тут!

Почніть тут!

Знайдіть відповіді зараз. Шукайте рішення самостійно або зверніться до нашого експерта.

Звернутися до служби підтримки

Звернутися до служби підтримки

Якщо вам потрібна допомога, додаткова інформація чи технічна підтримка або ви хочете подати скаргу, зв’яжіться з нашою командою з обслуговування клієнтів.

Де придбати?

Де придбати?

Зручний пошук найближчого дистриб’ютора, магазина або спеціалізованого партнера Schneider Electric у вашому регіоні.

Переглянути відповіді на поширені запитання

Переглянути відповіді на поширені запитання

Отримайте необхідну інформацію, переглянувши відповіді на поширені запитання за відповідними темами.

  • Документація Продукції
  • Завантаження ПЗ
  • Інструмент вибору продукту
  • Заміна та заміщення продукту
  • Контактний центр із надання довідки
  • Знайти наші представництва
  • Де купити
  • Спільнота Schneider Electric
  • Запит цінової пропозиції
  • Вакансії
  • Профіль компанії
  • Повідомити про проступок
  • Спеціальні можливості
  • Новини
  • Інвестори
  • EcoStruxure
  • Вакансії Пошук
  • Блог
  • Політика конфіденційності
  • Сповіщення про файли cookie
  • Умови користування
  • Change your cookie settings