Наші бренди

Impact-Company-Logo-English Black-01-177x54

Вітаємо на веб-сайті Schneider Electric

Ласкаво просимо на наш веб-сайт.
		
Чим ми можемо вам допомогти сьогодні?
SoMachine v3.1 application prompts that the 3S CanOpen Stack library is out of date. How do I resolve that issue?

Issue

When I build a Somachine v3.1 application it prompted me that the 3S CanOpen Stack library is out of date.  How do I resolve that issue?
Product Line
SoMachine v3.1, LMC058, LMC078, M238, M241, M251, M258, XBTGC, HMISCU
Environment
PLC Configuration Software for Windows
Cause
It is likely that an update of the application file has rendered the CANopenStack Library in the project older than the required version for the compiler.
Resolution

In order to get rid of the build error, you have to restore the proper version of the CANopenStack Library again. A backup copy of this library has been stored on the PC during installation of SoMachine. Please follow the following steps to get the correct library restored:

(1) Start a SoMachine session and open the project that shows up the build error

(2) Select the Library Repository function from the Tools main menu entry

(3) Select the “3S CANopenStack” library version 3.4.1.70 and uninstall the wrong library.

(4) In a next step install the correct library version. Press the Install… button in the Library Repository dialog, select the backup copy of the library, which is available in folder :

\Program Files\Schneider Electric\SoMachine\Support\

If you are running Windows 7/10 64bit, then the path would be: \Program Files (x86)\Schneider Electric\SoMachine\Support\

(5) Close the current project and reopen it again. This ensures that the new CANopenStack library is taken into account.

(6) When running another compilation of the project, the error message that was previously displayed, should no longer be valid

(7) Note that the restored library will not appear with a different revision then the old library.

If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance:

Support | Schneider Electric Global (se.com)

Schneider Electric Україна

Досліджуйте більше
Серія:
Досліджуйте більше
Серія:

Потрібна допомога?

  • Інструмент вибору продукту

    Швидко та легко знаходьте потрібні продукти й допоміжне обладнання для своїх завдань.

  • Розрахувати вартість

    Ставте свої запитання щодо продажів онлайн, і з вами зв’яжеться фахівець

  • Де придбати?

    Зручний пошук найближчого дистриб’ютора, магазина або спеціалізованого партнера Schneider Electric у вашому регіоні.

  • Довідковий центр

    Знайдіть усі необхідні ресурси для підтримки в одному місці.

  • Документація Продукції
  • Завантаження ПЗ
  • Інструмент вибору продукту
  • Заміна та заміщення продукту
  • Контактний центр із надання довідки
  • Знайти наші представництва"
  • Де купити
  • Спільнота Schneider Electric
  • Вакансії
  • Профіль компанії
  • Повідомити про проступок
  • Спеціальні можливості
  • Новини
  • Інвестори
  • EcoStruxure
  • Вакансії Пошук
  • Блог
  • Політика конфіденційності
  • Сповіщення про файли cookie
  • Умови користування
  • Change your cookie settings