How to check current size of the SQL Database PME
Issue
ION_Data database size needed for quoting PME upgrade, eService, Migration, or DB Maintenance.
Product Line
Power Monitoring Expert 7.2.2
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Cause 1
The current, database size is required and the quickest way to obtain that knowledge is desired
Cause 2
User does not have public access to SSMS
Cause 3
A diagnostic file is not available for SQL DB analysis
Cause 4
User does not have access to Database Manager.exe found in ".../Power Monitoring Expert/system/bin"
Resolution 1
- Open SSMS (you may use this application from the application server or from the DB server in cases where the PME application has been installed using the distributed architecture) and log in to the SQL Instance that PME is connected to
- Expand the "Databases" folder
- Right-Click on the ION_Data database
- Hover the mouse over Reports
- Hover the mouse over "Standard Reports"
- Select the "Disk Usage" report
example:
Resolution 2
- Open a file explorer from the PME Application server (the computer where the PME software has been installed locally)
- Navigate to the file path where the PME application has been installed (by default, PME will install to the C drive under the following file path: "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert...")
- Continue to navigate to the "Diagnostic Tools" folder
- Right-click the "Diagnostics Tool.exe" and select "Run as administrator"
- Verify the file path for the diagnostics tool's output
- Ensure that the "SQL Server Information" command has been selected within the list of commands on the right-hand side of the Diagnostics Tool
- Select "Start Analysis" within the Diagnostics Tool's UI
- Once complete, select the diagnostic that was created:
- Once the folder that contains the recently created diagnostic opens, select the "Ouputs" folder
- Select the "SQL Server Information.html"
example:
Resolution 3
- Open a file explorer from the PME Application server (the computer where the PME software has been installed locally)
- Navigate to the file path where the PME application has been installed (by default, PME will install to the C drive under the following file path: "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert...")
- Continue through the system folder, onto the bin folder
- Once in the bin folder, right-click the DatabaseManager.exe and select "Run as administrator"
- Once the program opens, right-click the ION_Data database and select the properties
Resolution 4
- Open a file explorer from the PME Application server (the computer where the PME software has been installed locally)
- Navigate to the file path where the PME application has been installed (by default, PME will install to the C drive under the following file path: "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert...")
- Continue through the system folder, onto the bin folder
- Once in the bin folder, select the "Vista.exe" application
- Use the PME credentials to log in to the Vista application
- In the top left hand side of the vista window select "File" then select "New"
- Use the "Diagram Objects" toolbox, usually located in the bottom right hand side of the screen to click and drag a "Data Log Viewer" onto the new vista page
- Right-click the data log viewer
- Select the tab from the configuration ui named "Query Server"
- Select "Customer Query Server", then select the "Edit Link..." button
- Double-click your query node, then double click the "Query Modules", the "Query 1" and then the "QM1 Query Register" in that order. Once that is complete, select "OK"
- Select the "Query" tab and select "Edit SQL"
- Type the following script into the notepad that appears on-screen:
EXEC sys.sp_spaceused - Close out of the notepad, and select "Save" when the popup windows appears to ask you if you'd like to save your changes to the notepad
- Select "OK" within your "Data Log Viewer Configuration" popup window
- Double-slick your Data Log Viewer
example of the results:
Опубліковано для: Schneider Electric Україна
Потрібна допомога?
Почніть тут!
Знайдіть відповіді зараз. Шукайте рішення самостійно або зверніться до нашого експерта.
Звернутися до служби підтримки
Якщо вам потрібна допомога, додаткова інформація чи технічна підтримка або ви хочете подати скаргу, зв’яжіться з нашою командою з обслуговування клієнтів.
Де придбати?
Зручний пошук найближчого дистриб’ютора, магазина або спеціалізованого партнера Schneider Electric у вашому регіоні.
Переглянути відповіді на поширені запитання
Отримайте необхідну інформацію, переглянувши відповіді на поширені запитання за відповідними темами.