Issue
Within the PME OPC Test Client, when attempting to connect to an OPC client, the software returns the following error: Could not load file or assembly 'OpcRcw.Ae'.. or one of its dependencies. The system cannot find the specified file.
Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
PME OPC Test Client
Cause
This error is caused by the 'OpcRcw.xx' files becoming corrupted.
Or
Power Monitoring Expert is unable to load the file or the defined assembly.
Resolution
**Warning: Take backups of any files before modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
Use the Power Monitoring Expert installation media to replace the OpcRcw.xx dll files within the "Power Monitoring Expert\system\bin" folder
- Obtain the Power monitoring Expert installation media that you are working with
- Right-click the installation media and select "Mount"
- Use the File Explorer to navigate to the computer's DVD Drive where the Power Monitoring Expert installation media will be mounted
- Once here, navigate to the following file path in the PME installation media -> DVD Drive ():\Setup\SetupSupport\OPC\setup.exe
- Right-click the "setup.exe" and select "Run as Administrator"
The OPC test client software should re-connect to the OPC client server without restarting the 'ION OPC Data Access Server' service.