Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
WebReach Historical Access Error on XP SP2

Goals and Symptoms

Summary
Permission Denied error when attempting to view historical data through Webreach on XP SP2 or Win 2003 Server SP1

Symptoms

This problem occurs on systems using Windows XP Service Pack 2 or 2003 Server SP1. The following error pops up when a user tries to View Data on a Data Log Viewer through WebReach:

Error Type:

PEGQuery (0x80040C8E)

Error with provideHTML. Error with GenerateHTML. WebReachHistoricalASP in GetQuery: -2147218290 Cannot execute default connection: An error occurred in GetConnectionStringFromQueryServer while attempting to access Query Server [QUERYSERVER.NITRO] with handle [327952]. The Query Server may not be running. Permission denied

Facts and Changes

Keywords
Webreach

Historical Data

XP SP2

2003 Server SP1

IIS

Permission Denied

Causes and Fixes

Cause
Due to the increased security settings applied in these service packs.

Resolution
There is currently no known resolution.

Workaround
Step 1: Setting Permissions

WebReach requires launch and activation privileges for the accounts used. This is performed using the Component Services applet, which can be found under Control Panel-> Administrative Tools. Once in Component Services proceed with the following steps:

1.       Expand Component Services and Computers respectively
2.       Right-click on My Computer
3.       Select Properties
4.       Choose the COM Security tab
5.       Under Launch and Activation Permissions, select Edit Default
6.       If the following accounts are not displayed, you will need to add them:
<machine name>\IUSR_<machine name>
<machine name>\IWAM_<machine name>

Component services

IF THE ACCOUNTS ARE NOT THERE:
To add these accounts, click to Add… button shown above in the Launch Permission window. This will lead to the following screen:

Computer select

You can add the user(s) under the local host computer name as shown above.
Once you create the users, make sure that the user(s) has/have permission to at least Remote Launch and Local Activation. Full access is advised if the user is the administrator. See below:

Permission set



Step 2:  Configuring Webreach

1.       Open Control Panel-> Windows Firewall.
2.       Select the Advanced tab
3.       Under Network Connection Settings, select Advanced Settings
Select Web Server(HTTP) as shown below

Firewall configuration

More Information
The workaround described above may resolve the problem with accessing historical data through WebReach when the error message is displayed such as:

PEGQuery error '80040c8e'
Error with provideHTML. Error with GenerateHTML. WebReachHistoricalASP in GetQuery: -2147218290 Cannot execute default connection: An error occurred in GetConnectionStringFromQueryServer while attempting to access Query Server [LOGSRV.STEADFAST] with handle [327952]. The Query Server may not be running. Automation error Catastrophic failure /ion/Historical/GetLogs.asp, line 40

Schneider Electric Việt Nam

Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings