Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
SoMachine v3.1 application prompts that the 3S CanOpen Stack library is out of date. How do I resolve that issue?

Issue

When I build a Somachine v3.1 application it prompted me that the 3S CanOpen Stack library is out of date.  How do I resolve that issue?
Product Line
SoMachine v3.1, LMC058, LMC078, M238, M241, M251, M258, XBTGC, HMISCU
Environment
PLC Configuration Software for Windows
Cause
It is likely that an update of the application file has rendered the CANopenStack Library in the project older than the required version for the compiler.
Resolution

In order to get rid of the build error, you have to restore the proper version of the CANopenStack Library again. A backup copy of this library has been stored on the PC during installation of SoMachine. Please follow the following steps to get the correct library restored:

(1) Start a SoMachine session and open the project that shows up the build error

(2) Select the Library Repository function from the Tools main menu entry

(3) Select the “3S CANopenStack” library version 3.4.1.70 and uninstall the wrong library.

(4) In a next step install the correct library version. Press the Install… button in the Library Repository dialog, select the backup copy of the library, which is available in folder :

\Program Files\Schneider Electric\SoMachine\Support\

If you are running Windows 7/10 64bit, then the path would be: \Program Files (x86)\Schneider Electric\SoMachine\Support\

(5) Close the current project and reopen it again. This ensures that the new CANopenStack library is taken into account.

(6) When running another compilation of the project, the error message that was previously displayed, should no longer be valid

(7) Note that the restored library will not appear with a different revision then the old library.

If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance:

Support | Schneider Electric Global (se.com)

Schneider Electric Việt Nam

Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings