Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
PME OPC Test Client: Could not load file or assembly 'OpcRcw.xx'

Issue
Within the PME OPC Test Client, when attempting to connect to an OPC client, the software returns the following error: Could not load file or assembly 'OpcRcw.Ae'.. or one of its dependencies. The system cannot find the specified file.

Pop-up window with error message "Could not load file or assembly" for OPC Test Client issue

Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024



Environment
PME OPC Test Client

Cause
This error is caused by the 'OpcRcw.xx' files becoming corrupted.

Or

Power Monitoring Expert is unable to load the file or the defined assembly.

Resolution
**Warning: Take backups of any files before modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).

Use the Power Monitoring Expert installation media to replace the OpcRcw.xx dll files within the "Power Monitoring Expert\system\bin" folder

  1. Obtain the Power monitoring Expert installation media that you are working with
    1. PMe installation media example
  2. Right-click the installation media and select "Mount"
    1. mount example
  3. Use the File Explorer to navigate to the computer's DVD Drive where the Power Monitoring Expert installation media will be mounted
  4. Once here, navigate to the following file path in the PME installation media -> DVD Drive ():\Setup\SetupSupport\OPC\setup.exe
    1. file explorer example
  5. Right-click the "setup.exe" and select "Run as Administrator"

The OPC test client software should re-connect to the OPC client server without restarting the 'ION OPC Data Access Server' service.

If you encounter this error at installation:

.NET Framework error


Verify the version of .NET Framework in the registry.

  1. In the Windows Search bar type "Run" and select the program.
  2. In Run, search for "regedit"regedit and select OK.
  3. Navigate to HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5. Confirm that .NET Framework 3.5 is installed. .NET Framework includes the feature set from .NET 2.0 and 3.0.

.NET Framework 3.5

If .NET Framework 3.5 is not installed, navigate to "Turn Windows Features on or off" and turn .NET Framework 3.5 on.

Schneider Electric Việt Nam

Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings