Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
Issues with data for measurements not being uploaded in PME after replacing a meter with a different device type

Issue
This issue can present itself after an older meter (such as a CM4000) has been replaced with a newer meter (such as a PM8000). See the related error below of measurements logged by the PM8000 that had been logged by the CM4000 but are not being processed properly. The follow errors are seen in the ION_SystemLog:

Timestamp: 9/9/2016 1:57:37.387 PM
Priority: WARNING
Source: LOGINSERTER.STANDALONE
Target:
Category: Computer Configuration
Computer: STANDALONE
Description: Unable to process records for Recorder 0x809@TEST.SWAPOUT. Class ID has not been retrieved for 0x9c01301@TEST.SWAPOUT.


Product Line
Power Monitoring Expert (PME) 7.2.x
Power Monitoring Expert (PME) 8.x
Power Monitoring Expert (PME) 9.x
Power Monitoring Expert (PME) 2020
Power Monitoring Expert (PME) 2021
Power Monitoring Expert (PME) 2022
Power Monitoring Expert (PME) 2023
Power Monitoring Expert (PME) 2024


Environment
Meter Replacement

Cause
The cause for this issue is when the meter is replaced and the device type is changed in PME with all the other information remaining the same. If the measurements for the device do not have the same ION handles that can cause a discrepancy with the way the device data is read. In this particular example, 0x9c01301 is an ION handle from the old CM4000 and does not exist on the new PM8000. This error prevents the log inserter from processing any inputs to the Data Recorder on the PM8000 with ION handle 0x809.

Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

It is possible to physically replace a meter with a meter of a different device type, such as replacing a CM4000 with a PM8000. In order to stop the error above and allow the Log Inserter to properly process the PM8000 data, entries in the IAS_MeasurementAddress table in ION_Network that reference this SourceID must be deleted.


Recommended procedure for meter swap outs:
After the device has been physically swapped out, prior to changing the device type in the Management Console.

Note: This example will use an ION7650 and all red text will need to be replaced by the given scenario's information.

  1. Stop all the ION Services
  2. Run the following queries to remove IAS_MeasurementAddress entries for the device(s) in question.
    1. Find the SourceID. Fill in the device name in the Group.Name format for the device you have swapped out as displayed in the Management Console (NOT the System Name).

USE ION_Network
SELECT SourceID FROM SRC_Source WHERE DisplayName = 'Group1.ION7650 '

For Example:
SourceID for device from ION_Network
The following queries will use 6 as an example SourceID, but it needs to be replaced the device's SourceID.

  1. It is recommended that a SELECT query be run prior to running the DELETE query to verify that the rows being deleted are the ones that should be deleted. Use the SourceID from the previous step

USE ION_Network
SELECT * FROM IAS_MeasurementAddress WHERE SourceID = 6

  1. Run the delete query using the SourceID from Step 2.a.

USE ION_Network
DELETE FROM IAS_MeasurementAddress WHERE SourceID = 6

  1. Change the device type in the Management Console.
  2. Start the ION services.


Note: When configuring a Data Log viewer in Vista, you will still see all the old data recorders associated with the old device. This may be OK if you want to see old data that was logged by the old device and is not being logged by the new device.

Alternatively, a SQL query is attached where the device name (entered as 'GroupName.DisplayName') can be entered between the apostrophe marks. Make sure the display name information is coming from what is shown in Management Console.

Schneider Electric Việt Nam

Phần đính kèm
clear_the_recorder.sql [2.17 KB]
Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings