Issue
During ‘Write to System’ in PME v9.0 CMT fails with below errors in CM Tool log -
Error||High||ZipManager||Bad state (invalid stored block lengths)
Error||High||Restore Network Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ION_Network.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||Restore Historical Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ION_Data.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||Restore AppMods Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ApplicationModules.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||VIPs||Source directory does not exist or could not be found: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\config\cfg\vip\VIP.UCION02P||Business
Error||High||System Registry||Registry.xml file cannot be found in the archive||Business
Environment
Power Monitoring Expert v9.0, Configuration Manager Tool v9.0
Cause
When the archive created in source system by CM Tool v9.0, the zip file included a corrupt file and that is causing the issue while unzipping by the CMT during write to system.
This will leads in multiple failed steps during write to system operation by CMT in target system.
Resolution
Try to unzip the archived file copied from source system using 7z app, you may notice errors like Data error and complete path of the file which is having issue.
So using same tool (7z) open the zip file and delete the corrupt file and verify no errors exist during by 7Z app.
Now run CM Tool for ‘Write to system’ operation.
During ‘Write to System’ in PME v9.0 CMT fails with below errors in CM Tool log -
Error||High||ZipManager||Bad state (invalid stored block lengths)
Error||High||Restore Network Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ION_Network.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||Restore Historical Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ION_Data.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||Restore AppMods Database||Cannot open backup device 'C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\Database_Backups\ApplicationModules.bak'. Operating system error 3(The system cannot find the path specified.).
Error||High||VIPs||Source directory does not exist or could not be found: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\CM Migration Files\88e4374e\config\cfg\vip\VIP.UCION02P||Business
Error||High||System Registry||Registry.xml file cannot be found in the archive||Business
Environment
Power Monitoring Expert v9.0, Configuration Manager Tool v9.0
Cause
When the archive created in source system by CM Tool v9.0, the zip file included a corrupt file and that is causing the issue while unzipping by the CMT during write to system.
This will leads in multiple failed steps during write to system operation by CMT in target system.
Resolution
Try to unzip the archived file copied from source system using 7z app, you may notice errors like Data error and complete path of the file which is having issue.
So using same tool (7z) open the zip file and delete the corrupt file and verify no errors exist during by 7Z app.
Now run CM Tool for ‘Write to system’ operation.