Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
EcoStruxure Control Expert - Impossible to go in on-line mode / Error 203 message when connecting to PLC from DTM Browser

!!!Confidential Content

Issue

When in the EcoStruxure Control Expert > DTM Browser window, and attempting to Connect to the BMEP58_ECPU_EXT node via EIP Explicit communication, we get the messages:

"Impossible to go in on-line mode."

and "NA_Config Cannot StartDriver (Error 203)"

Error message dialogs

Product Line

EcoStruxure Control Expert

Cause

There are a few common causes:

A) There is a physical break in the ethernet connection

B) The IP Address Subnet of the computer is different than the PLC

C) There is a managed switch or firewall rule blocking the Ethernet/IP TCP port 44818

D) There is a separate application that is running on the computer that is reserving TCP port 44818 for itself

Resolution

Steps to troubleshoot:

For (A) physical break in the ethernet connection and (C) a managed switch or firewall rule blocking the Ethernet/IP TCP port 44818

1) Try a running a new CAT5E cable directly between your laptop/workstation running EcoStruxure Control Expert and the PLC.

2) If it works, inspect your old cable for failure, and/or inspect the settings on your managed switch to ensure passage of TCP and UDP packets on port 44818 to the PLC.

NOTE:

If the network is managed by an IT department, please contact them and tell them you would like to free up the TCP and UDP port 44818 and UDP port 2222 for Ethernet/IP communication.

For (B) IPv4 Subnet of the computer is different than the PLC

1) Go to Control Panel

2) Go to Network and Sharing Center

3) Click on "Change adapter settings"

4) Right-click and go to Properties on the Network you wish to view/edit

5) Click on "Internet Protocol Version 4 (TCP/IPv4)"

6) Change the IP Address to match the subnet of the PLC.

IP Address setting in Windows

7) Hit OK and OK again

8) In the DTM Browser screen, double-click on the PLC node (1st node directly under "Host PC")

9) In the Channel Properties, Source Address section, click on the dropdown next to IP Address Source (PC)

10) Choose the IP Address associated with the Network node of your PC

IP Address Source (PC) dropdown

11) If you needed to change this, hit [Apply] at the bottom corner.

12) Check that it matches the IP Address of the PLC from the Channel Properties > TCP/IP node:

IP Address of PLC

In the case of (D) there is a separate application that is running on the computer that is reserving TCP port 44818 for itself

1) From the Start bar search box, type "Resource Monitor"

2) Run the Windows Resource Monitor

3) Go to the Network Tab

4) Expand Listening Ports

5) Sort by the Port column

6) Find 44818

7) If the Image name is not "ControlExpert.exe", take note of what is the Image and PID of this row, this will be the software which is blocking the port.

Windows Resource Monitor - Listening Ports

For example:

If you have Rockwell Studio 5000 software installed on the same computer.

Even if Rockwell Studio is not running or RSLinx itself is not running, the process "RSLinxNG.exe" running a service called "FactoryTalk Linx OPC Runtime Service" reserves the port 44818.

One will need to stop the service from Windows Services and then ensure that the PID is indeed Terminated:

RSLinxNG.exe service

That will free up the port and allow Control Expert to use it and allow the DTM connection to the M580.

Schneider Electric Việt Nam

Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings