Unable to login or access thick apps or web application from the Power Monitoring Expert engineering client after a clean install
Issue
The thick apps and the web application will be inaccessible
The error message when attempting to login to the thick apps will look like the following screen capture:
The error shown in the web application will look like the following screen capture
The error will look like the following in text:
A problem occurred calling provider 789d8792-8f58-42c4-aa24-f1b6818edba7 with parameters [5]: Status has not been requested from the provider engine
Product Line
Power Monitoring Expert 7.2.2
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Thick Apps (Management Console, Vista, etc.)
Web Application
Cause
Cause 1:
The Power Monitoring Expert System guide states the following:
The PME server, database server, and clients must be able to communicate with each other over the network using the TCP/IP protocol. The licensing component of PME requires that PME clients and the server can resolve each other’s addresses by name (not just fully qualified domain names or IP addresses). If a proxy server is used on the network, then a local address bypass must be configured on the PME server. An Internet connection is not required for PME to function correctly.
Cause 2:
The kerberos client receives an error message when the eng client tries logging into the thick apps causing the login to fail. The screen capture below depicts the error message received in the window's event viewer
Resolution
Resolution 1:
Check the windows settings of the PME app server, the database server (if distributed architecture) and the eng client to make sure that either there is no proxy server set or that it is being bypassed. The following screen capture shows the windows setting page where this can be configured
bypass proxy server
no proxy server being used
no proxy server being used
Resolution 2:
The following screen capture shows the commands needed to set the SPN, resolving the error seen in the window's event viewer.
However, in some cases, the PME services are being run by a service account instead of the default accounts (local system, local service, network service, etc.). In this case, the PME application (and the security token generated when a user attempts to login to the thick apps) will no longer be recognized by Kerberos as the server's name, but instead will be recognized as the service account's name.
To resolve the error message seen in the window's event viewer, you must create an alias for the service name running under the server's name, by creating an SPN record using the server and service name
For example:
SETSPN -S HTTP/<Server Name> <DOMAIN>\<Account> This can be seen in the example line printed from the CMD PRMPT screen capture above.
Đã phát hành cho: Schneider Electric Việt Nam
Bạn cần trợ giúp?
Công cụ chọn sản phẩm
Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.
Nhận báo giá
Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.
Nơi mua hàng?
Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.
Trung tâm Hỗ trợ
Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.