How to Properly View Downloaded Log Files from the SAGE RTU
Issue:
Downloaded Log files from the SAGE RTU Graphic User Interface (GUI) appear in unreadable characters (e.g., Chinese symbols) when opened in standard text editors like Notepad.
Product:
Sage RTU Series (SAGE 1X10, 1X30, 1X50, 2X00, 3030X)
Environment:
- SAGE RTU GUI
- Windows OS (using default Notepad)
- Log files downloaded from RTU
Cause:
The issue occurs because the files use UTF-8 encoding, and standard Notepad does not properly interpret this encoding by default, resulting in unreadable characters.
Resolution:
- Use a text editor that supports UTF-8 encoding, such as Notepad++ (recommended).
- If the file still shows NULL or strange symbols:
- In Notepad++, go to Encoding → Convert to UTF-8.
- Save and reopen the file; it should display correctly now.
- Alternative applications:
- WordPad
- Spreadsheet viewers (e.g., Excel)
- Ensure the file is not corrupted before conversion.
Example, Using Notepad:
Using NotePad++:
Using a spreadsheet viewer:
Đã phát hành cho: Schneider Electric Việt Nam
Bạn cần trợ giúp?
Công cụ chọn sản phẩm
Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.
Nhận báo giá
Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.
Nơi mua hàng?
Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.
Trung tâm Hỗ trợ
Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.