Чим ми можемо вам допомогти сьогодні?

Power Monitoring Expert (PME) "Server Error in '/Dashboards' Application. An error occurred during the compilation of a resource. . .The type or namespace name 'ErrorMessageModel' does not exist in the namespace 'Framework.Web.Exceptions' (are you missing

Issue
The Power Monitoring Expert (PME) Web application dashboards cannot be accessed due to the error message below. If "show detailed compiler output" is selected, a comment is shown "this compiler is provided as part of the Microsoft (R) .NET Framework, but only supports language versions up to C# 5, which is no longer the latest version."

"Server Error in

"Server Error in '/Dashboards' Application.

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0234: The type or namespace name 'ErrorMessageModel' does not exist in the namespace 'Framework.Web.Exceptions' (are you missing an assembly reference?)"

Source File: C:\Windows\Microsoft.NET\Framework…"

Product line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment
Power Monitoring Expert (PME)
PME Web Applications
Microsoft .NET

Cause
Per the Power Monitoring Expert (PME) system guide, there is a specific .NET version required for the software components. If the .NET version files are not detected, it can cause errors due to missing files.

Resolution
Check your PME System Guide and/or IT guide to verify the correct .NET version is installed for your PME system. You can download the system guide and IT guide for your PME version here https://www.se.com/ww/en/download/.

Schneider Electric Україна

Потрібна допомога?

Потрібна допомога?

Почніть тут!

Почніть тут!

Знайдіть відповіді зараз. Шукайте рішення самостійно або зверніться до нашого експерта.

Звернутися до служби підтримки

Звернутися до служби підтримки

Якщо вам потрібна допомога, додаткова інформація чи технічна підтримка або ви хочете подати скаргу, зв’яжіться з нашою командою з обслуговування клієнтів.

Де придбати?

Де придбати?

Зручний пошук найближчого дистриб’ютора, магазина або спеціалізованого партнера Schneider Electric у вашому регіоні.

Переглянути відповіді на поширені запитання

Переглянути відповіді на поширені запитання

Отримайте необхідну інформацію, переглянувши відповіді на поширені запитання за відповідними темами.

  • Документація Продукції
  • Завантаження ПЗ
  • Інструмент вибору продукту
  • Заміна та заміщення продукту
  • Контактний центр із надання довідки
  • Знайти наші представництва
  • Де купити
  • Спільнота Schneider Electric
  • Запит цінової пропозиції
  • Вакансії
  • Профіль компанії
  • Повідомити про проступок
  • Спеціальні можливості
  • Новини
  • Інвестори
  • EcoStruxure
  • Вакансії Пошук
  • Блог
  • Політика конфіденційності
  • Сповіщення про файли cookie
  • Умови користування
  • Change your cookie settings