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Unablet to open the Alarms tab after upgrading to PME 9.0.

Published date: 04 November 2019

 ISSUE:

The foillowing message is displayed when trying to open the Alarms tab from the Wep Applications
after upgrade to PME 9.0.
"Alarms is processing existing records for the first time use.
The Alarms application will be ready for use once the historical processing is complete"




PRODUCT LINE: 
Power Monitoring Expert


ENVIRONMENT: 
Web Applications in Power Monitoring Expert


CAUSE:
The Alarm tab is not opening and the Progress Report shows 0% complete even after the Refresh link
is pressed several times. The diagnostic system log shows this message below.
"Could not find Store Prprocedure 'dbo.CleanCorruptincidentsAndAlarms"


RESOLUTION:
 *Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with
SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*


*Warning: Take backups of any files prior to modifying them. Ensure the backups
are in a location that will not be overwritten (i.e. the Desktop).

Go to SQL Management Studio and run the attached SQL query to create the
'dbo.CleanCorruptincidentsAndAlarms Store Procedure.
Once the query is ran, verify the Store Proecedure is created under ION_Data\Programmability\StoereProcedure.







 

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