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Summary Report Pack will not install via the Web Interface

Issue
Summary Report Pack will not install via the Web Interface, the following error is displayed as seen below.
Error installing report pack. An error was encountered while processing the report pack
'Summary Report Pack 4.3'. Please contact technical support.
Summary Report Pack 4.3

This process is the same for Summary Report Pack 5.2 as shown below
Summary Report Pack 5.2

Product Line
StruxureWare Power Monitoring 7 or 7.0.1
Power Monitoring Expert 7.2.x
Power Monitoring Expert for Data Centers 7.2.x
Power Monitoring Expert for Health Care 7.2.x
Summary Reports Packs versions 4.0, 4.2, and 4.3
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Summary Report Pack 5.2
Summary Report Pack 6.0

Environment
StruxureWare Power Monitoring 7.0.x and StruxureWare Power Monitoring Expert 7.2.x with Summary Reports Pack
Power Monitoring Expert 8.2 with Summary Report Pack 5.2, Power Monitoring Expert 9.0 with Summary Report Pack 6.0

Cause
Cannot install Summary Report Pack via the SPM/PME Web interface

Resolution

Step 1
Use the ReportPackUtil.exe found in the \system\bin folder of the SPM/PME installation.

The command to install the report pack would be:

ReportPackUtil.exe –root <SPM/PME\web> - install <ReportPackName>

Note:
<SPME/PME\web>: is the directory where SPM/PME is installed in the server

<ReportPackName>: this is the name of the report pack without the file extension name

Example:

ReportPackUtil.exe -root "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\web" -install "Summary Report Pack 4.2"



-install "Summary Report Pack 4.2"

Verification of Summary Report Pack 5.2 installed
Verification of Summary Report Pack 5.2 installed

If the report pack does not install through command line a stack trace will be produced with details regarding why the install did not succeed.  One of the most common reasons is the stack trace shown in the screen shot below.


stack trace

The error states "The process cannot access the file 'C:\Program Files (x86)\Schneider Electric\ION Enterprise\system\bin\Reporting.LogicalMeasurementExtension.Argument.dll' because it is being used by another process.
This can be caused by the ION Report Subscription Service running.
This error can occur when attempting to install any Report Pack from command line so the service needs to be stopped before it can be installed successfully.

In order to stop the service go to the start menu and search for "services.msc" to load the services interface.
On the service "ION Report Subscription Service" right click and select the Stop option.
Run the Report Pack installer from command line once again and, once it succeeds, then right click on the ION Report Subscription Service and select the Start option.

Step 2
Use the ObjectFactoryTools.exe found in the \web\bin folder of the SPM/PME installation.  This configures any custom controls the report pack needs to run.

The command to configure the report pack would be:
ObjectFactoryTools.exe configure

This is required in order for all the custom controls in the Summary Report Pack to be recognized by the Object Factory Tools.

Note:
Make sure you run the executable located in the web\bin folder, and not the one located in the system\bin

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