Issue:
Customer has good power to the drive but the display is not turning on.
Product Line:
Altivar Process ATV600 and ATV900 drives
Altivar Machine ATV340 and ATV320 drives
Environment:
Ethernet connection
Cause:
Incorrect wiring to the keypad or Modbus port
Resolution:
Verify the keypad will power up properly without external networking connections by unplugging the network connection from the drive..
- If the keypad does not come on, confirm good line voltage is present and check 24V and 10V DC power supplies (measured to COM not Ground) on the control terminals. If power supplies are low or missing, remove wiring to +24 and +10 terminals and then recheck. If power supplies are still low and display is still blank, there is a problem in the drive.
- If the keypad does power up with no external connections but goes blank when the cable is plugged in, then there is a problem with the network connection and the wiring needs to be reviewed and corrected..
The most common cause of this issue is when an Ethernet connection is plugged into a Modbus serial port.
This is an easy error to make, since both use the same RJ45 connector.
The ModBus port has a power supply built into pins 7 and 8 on the RJ45, (used to power a remote keypad or the SoMove USB cable).
Ethernet uses pins 7 and 8 for data communications.
So connecting an Ethernet connection into a Modbus port will short out the power supply (10 or 12VDC depending on the product) and will cause the display to go out.
This will also trigger and error in the drive and it will be unable to operate.
The local display (if there is one) will also go out.